6 stycznia została wydana najnowsza wersja WordPressa oznaczona jako 4.4.1. Jest to pilne uaktualnienie przez wzgląd na bezpieczeństwo, dlatego też poleca się wszystkim administratorom zainstalowanie go jak najszybciej.

Odkryto bowiem, że wersja 4.4 oraz wcześniejsze posiadają lukę typu cross-site scripting przez co zagrożona stała się większość witryn korzystające z WordPressa.

Poza główną poprawką pojawił się szereg zmian oraz nowości, a dotyczą one głównie wyświetlania wybranych elementów panelu administracyjnego, nowych ikon Emoji, przetwarzania komentarzy czy formatowania danych.

Przy okazji tego typu szybkich u automatycznych uaktualnień zainstalować jednokrotnie wtyczkę Readme detonator, która usuwa plik readme.html po każdej instalacji oraz meta tagi związane z WordPressem.

Przy tej aktualizacji zmianie uległy następujące pliki:

/wp-admin/users.php

/wp-admin/includes/class-wp-filesystem-ftpext.php

/wp-admin/includes/screen.php

/wp-admin/includes/class-wp-screen.php

/wp-admin/includes/class-wp-filesystem-ftpsockets.php

/wp-admin/js/postbox.min.js

/wp-admin/js/common.min.js

/wp-admin/js/postbox.js

/wp-admin/js/common.js

/wp-admin/about.php

/wp-login.php

/wp-includes/class-wp.php

/wp-includes/comment.php

/wp-includes/class-IXR.php

/wp-includes/functions.php

/wp-includes/embed.php

/wp-includes/widgets/class-wp-widget-rss.php

/wp-includes/random_compat/random_bytes_dev_urandom.php

/wp-includes/random_compat/random.php

/wp-includes/query.php

/wp-includes/class-wp-walker.php

/wp-includes/taxonomy.php

/wp-includes/certificates/ca-bundle.crt

/wp-includes/class-wp-theme.php

/wp-includes/customize/class-wp-customize-themes-section.php

/wp-includes/widgets.php

/wp-includes/comment-template.php

/wp-includes/nav-menu-template.php

/wp-includes/formatting.php

/wp-includes/class-phpmailer.php

/wp-includes/version.php

/wp-includes/class-oembed.php

/wp-includes/media.php

/wp-includes/embed-template.php

/wp-includes/class-smtp.php

/wp-includes/link-template.php

/wp-includes/update.php

/wp-includes/post.php

/wp-includes/js/wp-emoji-release.min.js

/wp-includes/js/wp-emoji-loader.js

/wp-includes/js/twemoji.min.js

/wp-includes/js/autosave.min.js

/wp-includes/js/wp-emoji.min.js

/wp-includes/js/twemoji.js

/wp-includes/js/autosave.js

/wp-includes/js/media-views.min.js

/wp-includes/js/wp-emoji-loader.min.js

/wp-includes/js/wp-emoji.js

/wp-includes/js/media-views.js

/wp-includes/shortcodes.php

/wp-includes/category-template.php

/wp-includes/class-wp-xmlrpc-server.php

/wp-includes/general-template.php

/wp-config-sample.php

/wp-content/plugins

/license.txt

/readme.html

2 KOMENTARZE

ZOSTAW ODPOWIEDŹ