Weekend skończył się pracowicie dla administratorów stron na WordPressie. Najszybciej jak to możliwe poinformowałem Was o problemach z bezpieczeństwem 11 wtyczek. Tym razem mam kolejne dobre wieści. Z kolejnych doniesień wiadomo, że aż około 1 020 000 stron może paść łupem hakerów. Oto których wtyczek dotyczą:

 

404 to 301

(aktywny na ponad 30 000 witryn)

Wszystkie wersje od 2.0.2 w dół są wrażliwe na atak typu Authenticated Blind SQL Injection. Informacja ta obiegła dzisiaj Internet, a uaktualnienie Duplicatora do wersji 2.0.3 łata lukę.

 

Display Widgets

(aktywny na ponad 200 000 witryn)

Plugin pozwalający ukrywać widgety na konkretnych podstronach witryn pod WordPressem jest wrażliwy na atak XSS. Osoby posiadające aktywną wersję <= 2.03 powinny czym prędzej uaktualnić wtyczkę do wersji 2.04.

 

WP Database Backup

(aktywny na ponad 30 000 witryn)

Plugin pomagający stworzyć kopię zapasową bazy danych w wersji 3.3 i niższych narażony jest na atak Authenticated Persistent Cross-Site Scripting (XSS). Na szczęście uaktualnienie  do 3.4 naprawia sytuację.

 

Easy Social Icons

(aktywny na ponad 40 000 witryn)

Ten popularny na polskojęzycznych stronach plugin w wersji 1.2.3.1 i niższych posiada podatność na ataki typu Authenticated SQL Injection. Użytkownikom zaleca się jak najszybsze uaktualnienie do wersji 1.2.4.

 

WP Job Manager

(aktywny na ponad 50 000 witryn)

WP Job Manager w wersji 1.23.7 oraz niższych podatny jest na atak XSS (Unauthenticated Reflected Cross-Site Scripting). Więcej informacji na temat wykrytego problemu można znaleźć tutaj, a uaktualnienie pluginu do wersji 1.23.8 naprawia błąd.

 

WP Google Map Plugin

(aktywny na ponad 50 000 witryn)

Ta popularna, a i bardzo użyteczna wtyczka posiada w wersji 2.3.9 i niższych lukę umożliwiającą przeprowadzić atak typu Authenticated Cross-Site Scripting (XSS). Na szczęście problem naprawia uaktualnienie do wersji 3.0.0, dlatego też jeżeli korzystacie z tej wtyczki, to powinniście jak najszybciej przeprowadzić uaktualnienie lub skorzystać z automatycznej aktualizacji (pisałem o tym więcej w tym poście).

 

Visitor Maps and Who’s Online

(aktywny na ponad 40 000 witryn)

Ta wyświetlająca geolokalizację odwiedzających wtyczka w wersji 1.5.8.6 i niższych jest wrażliwa na atak Authenticated Persistent Cross-Site Scripting (XSS). Zaleca się jak najszybszą aktualizację do wersji 1.5.8.7. Ta bowiem naprawia wspomniany błąd.

 

Image Gallery

(aktywny na ponad 50 000 witryn)

Ta popularna wtyczka, podobnie jak praktycznie wszystkie wrażliwa jest na atak Authenticated Cross-Site Scripting (XSS). Wrażliwe są wersje niższe lub równe wersji 1.5.1, a łata ją uaktualnienie do wersji 1.5.6.

 

Alpine PhotoTile for Instagram

(aktywny na ponad 40 000 witryn)

Dzisiaj odkryto trzecią już w tej wtyczce lukę w przeciągu ostatnich 15 miesięcy. Tym razem jest to luka typu Authenticated Cross-Site Scripting (XSS) i występuje w wersji 1.2.7.5 i niższych. Aby być bezpiecznym należy uaktualnić wtyczkę do wersji 1.2.7.6.

 

Master Slider – Responsive Touch Slider

(aktywny na ponad 60 000 witryn)

Ten popularny, responsywny slider posiada w wersji 2.5.1 i niższej lukę typu Authenticated Blind SQL Injection. Problemu można pozbyć się zmieniając wersję pluginu na 2.5.2.

 

Tribulant Slideshow Gallery

(aktywny na ponad 50 000 witryn)

Tribulant Slideshow Gallery w wersji 1.5.3 i niższej jest podatny na atak Arbitrary file upload & Cross-Site Scripting (XSS). Uaktualnienie wtyczki galerii do 1.5.3.4 naprawia problem.

 

Contact Form Builder

(aktywny na ponad 60 000 witryn)

Tutaj należy się plus za szybką reakcję. Choć w wersji 1.0.24 znajdujemy problem bezpieczeństwa typu Authenticated Blind SQL Injection, to wydana już wersja 1.0.25 rozwiązuje problem.

 

Floating Social Media Icon

(aktywny na ponad 60 000 witryn)

Floating Social Media Icon obecny na ponad 60 tysiącach stron posiada w wersji 2.1 lukę typu Authenticated Persistent Cross-Site Scripting (XSS). Uaktualnienie do wersji 2.2 rozwiązuje sprawę, dlatego zaleca się pobranie jej najszybciej jak to możliwe.

 

Google Language Translator

(aktywny na ponad 80 000 witryn)

Wtyczka ta posiada w wersji 4.0.9 problem Authenticated Cross-Site Scripting (XSS) i narażał użytkowników na włamanie. Wydane już uaktualnienie rozwiązuje problem, dlatego jak najszybciej należy uaktualnić wtyczkę do wersji 5.0.0.

 

Dynamic Widgets

(aktywny na ponad 80 000 witryn)

To już drugi problem w kwestii bezpieczeństwa tej wtyczki. Tym razem problem występuje w wersji 1.5.10 i posiada lukę Authenticated Cross-Site Scripting (XSS). Aby pozbyć się problemu należy uaktualnić plugin do wersji 1.5.11.

 

Slider

(aktywny na ponad 100 000 witryn)

Wtyczka o nazwie Slider posiada w wersji 2.8.6 i niższych problem typu Authenticated Blind SQL Injection. Więcej można przeczytać o nim na tej stronie, a uaktualnienie do 2.8.7 powinno chociaż tymczasowo pomóc.

BRAK KOMENTARZY

ZOSTAW ODPOWIEDŹ